Flash Player <= 220.127.116.116 Multiple Vulnerabilities (APSB15-04)
High Nessus Network Monitor Plugin ID 8660
SynopsisThe remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.
DescriptionVersions of Adobe Flash player equal or prior to 18.104.22.1686 are outdated and thus unpatched for the following vulnerabilities :
- Several use-after-free errors exist that allow arbitrary code execution. (CVE-2015-0313, CVE-2015-0315, CVE-2015-0320, CVE-2015-0322)
- Several memory corruption errors exist that allow arbitrary code execution. (CVE-2015-0314, CVE-2015-0316, CVE-2015-0318, CVE-2015-0321, CVE-2015-0329, CVE-2015-0330)
- Several type confusion errors exist that allow arbitrary code execution. (CVE-2015-0317, CVE-2015-0319)
- Several heap-based buffer overflow errors exist that allow arbitrary code execution. (CVE-2015-0323, CVE-2015-0327)
- A buffer overflow error exists that allows arbitrary code execution. (CVE-2015-0324
- Several NULL pointer dereference errors exist that have unspecified impacts. (CVE-2015-0325, CVE-2015-0326, CVE-2015-0328).
- A use-after-free error exists within the processing of invalid m3u8 playlists. A remote attacker, with a specially crafted m3u8 playlist file, can force a dangling pointer to be reused after it has been freed, allowing the execution of arbitrary code. (CVE-2015-0331)
SolutionUpgrade to Adobe Flash Player version 22.214.171.1245 or later.\n\nAlternatively, Adobe has made version 126.96.36.1999 available for those installs that cannot be upgraded to 16.x.