Flash Player < 17.0 Multiple Vulnerabilities (APSB15-05)

High Nessus Network Monitor Plugin ID 8654

Synopsis

The remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.

Description

Versions of Adobe Flash player prior to 17.0 are outdated and thus unpatched for the following vulnerabilities :

- Multiple memory corruption vulnerabilities exist due to improper input validation. A remote attacker could exploit these to execute arbitrary code. (CVE-2015-0332, CVE-2015-0333, CVE-2015-0335, CVE-2015-0339)

- Multiple type confusion flaws exist, which an attacker could exploit to execute arbitrary code. (CVE-2015-0334, CVE-2015-0336)

- An unspecified flaw exists that allows an attacker to bypass cross-domain policy. (CVE-2015-0337)

- An integer overflow vulnerability exists due to improper input validation, which an attacker can exploit to execute arbitrary code. (CVE-2015-0338)

- An unspecified flaw exists that allows an attacker to bypass restrictions and upload arbitrary files. (CVE-2015-0340)

- Multiple use-after-free vulnerabilities exist that can allow an attacker to dereference memory which has already been freed and execute arbitrary code. (CVE-2015-0341, CVE-2015-0342)

Solution

Upgrade to Adobe Flash Player version 17.0.0.134 or later.\n\nAlternatively, Adobe has made version 13.0.0.277 available for those installs that cannot be upgraded to 17.x.

See Also

http://helpx.adobe.com/security/products/flash-player/apsb15-05.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: High

ID: 8654

Family: Web Clients

Published: 2015/03/27

Modified: 2018/09/16

Dependencies: 5158

Nessus ID: 81819

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2015/03/12

Vulnerability Publication Date: 2015/03/12

Exploitable With

Metasploit (Adobe Flash Player NetConnection Type Confusion)

Reference Information

CVE: CVE-2015-0332, CVE-2015-0333, CVE-2015-0334, CVE-2015-0335, CVE-2015-0336, CVE-2015-0337, CVE-2015-0338, CVE-2015-0339, CVE-2015-0340, CVE-2015-0341, CVE-2015-0342

BID: 73080, 73081, 73082, 73083, 73084, 73085, 73086, 73087, 73088, 73089, 73091

IAVA: 2015-A-0057