Flash Player < 17.0 Multiple Vulnerabilities (APSB15-05)
High Nessus Network Monitor Plugin ID 8654
SynopsisThe remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.
DescriptionVersions of Adobe Flash player prior to 17.0 are outdated and thus unpatched for the following vulnerabilities :
- Multiple memory corruption vulnerabilities exist due to improper input validation. A remote attacker could exploit these to execute arbitrary code. (CVE-2015-0332, CVE-2015-0333, CVE-2015-0335, CVE-2015-0339)
- Multiple type confusion flaws exist, which an attacker could exploit to execute arbitrary code. (CVE-2015-0334, CVE-2015-0336)
- An unspecified flaw exists that allows an attacker to bypass cross-domain policy. (CVE-2015-0337)
- An integer overflow vulnerability exists due to improper input validation, which an attacker can exploit to execute arbitrary code. (CVE-2015-0338)
- An unspecified flaw exists that allows an attacker to bypass restrictions and upload arbitrary files. (CVE-2015-0340)
- Multiple use-after-free vulnerabilities exist that can allow an attacker to dereference memory which has already been freed and execute arbitrary code. (CVE-2015-0341, CVE-2015-0342)
SolutionUpgrade to Adobe Flash Player version 126.96.36.199 or later.\n\nAlternatively, Adobe has made version 188.8.131.527 available for those installs that cannot be upgraded to 17.x.