Squid 2.7.x < 3.0 DoS

High Nessus Network Monitor Plugin ID 8636

Synopsis

The remote proxy server is affected by a denial of service vulnerability.

Description

Squid versions 2.7.x prior to 3.0 are affected by a denial of service vulnerability due to a miscalculation of memory size when handling HTTP header values. Specifically, this issue affects the 'httpMakeVaryMark()' function of the 'src/http.cc' source file. This causes an assertion to fail, and repeated failures can cause the service to terminate.

A remote attacker can exploit this vulnerability by sending a specially crafted HTTP request. Authentication may or may not be required depending on the server's configuration. Successful exploitation will cause the Squid service to terminate.

Solution

Either upgrade to Squid version 3.0 or later, or apply the vendor-supplied patch.

See Also

http://www.squid-cache.org

http://telussecuritylabs.com/threats/show/TSL20130308-03

http://seclists.org/fulldisclosure/2013/Mar/62

Plugin Details

Severity: High

ID: 8636

File Name: 8636.prm

Family: Web Servers

Published: 2015/05/21

Modified: 2016/01/15

Dependencies: 3389

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Patch Publication Date: 2013/03/14

Vulnerability Publication Date: 2013/03/05

Reference Information

BID: 58322