Squid 3.x < 3.2.9 / 3.3.x < 3.3.3 DoS

High Nessus Network Monitor Plugin ID 8635

Synopsis

The remote proxy server is affected by two denial of service vulnerabilities.

Description

Squid versions 3.2.x prior to 3.2.9, and 3.3.x prior to 3.3.3 are affected by two denial of service vulnerabilities. These vulnerabilities exist due to an error in processing the HTTP header values and due to a miscalculation of memory size when handling HTTP header values. Specifically, these issues affect the 'httpMakeVaryMark()' function of the 'src/http.cc' source file. Attackers can exploit this issue to terminate the main process of squid (parent), resulting in denial of service conditions.

Solution

Either upgrade to Squid version 3.2.9, 3.3.3 or later, or apply the vendor-supplied patch.

See Also

http://www.squid-cache.org

http://telussecuritylabs.com/threats/show/TSL20130308-03

http://seclists.org/fulldisclosure/2013/Mar/62

Plugin Details

Severity: High

ID: 8635

Family: Web Servers

Published: 2015/05/21

Modified: 2016/11/23

Dependencies: 3389

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Patch Publication Date: 2013/03/14

Vulnerability Publication Date: 2013/03/05

Reference Information

BID: 58319, 58322