Flash Player < 184.108.40.206 (inferred) Multiple Vulnerabilities (APSB14-27)
High Nessus Network Monitor Plugin ID 8604
SynopsisThe remote host is running a browser plugin that is affected by multiple vulnerabilities.
DescriptionVersions of Adobe Flash player equal or prior to 220.127.116.11 are outdated and thus unpatched for the following vulnerabilities :
- A security bypass vulnerability that allows an attacker to bypass the same-origin policy (CVE-2014-0580).
- Multiple memory corruption vulnerabilities that allow an attacker to execute arbitrary code (CVE-2014-0587, CVE-2014-9164).
- A use-after-free vulnerability that can result in arbitrary code execution (CVE-2014-8443).
- An unspecified information disclosure vulnerability (CVE-2014-9162).
- A stack-based buffer overflow vulnerability that can be exploited to execute arbitrary code or elevate privileges (CVE-2014-9163).
SolutionUpgrade to 18.104.22.168 from the vendor's website. Flash Player for Google Chrome and Internet Explorer should contain the next version of the Flash engine in their monthly updates. Users of Extended Support Release are recommended to run Flash 22.214.171.1249, while Linux users should update to version 126.96.36.1995.