phpMyAdmin 4.0.x < 4.0.10.7 / 4.1.x < 4.1.14.8 / 4.2.x < 4.2.13.1 DoS (PMASA-2014-17)

Medium Nessus Network Monitor Plugin ID 8592

Synopsis

The remote web server contains a PHP application that is affected by a potential denial of service vulnerability.

Description

Versions of phpMyAdmin earlier than 4.0.10.7, 4.1.14.8, or 4.2.13.1 are unpatched for a denial of service vulnerability due to the way the application handles very long passwords. An attacker attempting to authenticate repeatedly using a large password string may be able to trigger this condition on the server.

Solution

Either upgrade to phpMyAdmin 4.0.10.7, 4.1.14.8, 4.2.13.1 or later, or apply the patches from the referenced links.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2014-17.php

Plugin Details

Severity: Medium

ID: 8592

Family: CGI

Published: 2014/12/08

Modified: 2016/03/02

Dependencies: 9102

Nessus ID: 79797

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2014/12/03

Vulnerability Publication Date: 2014/12/03

Reference Information

CVE: CVE-2014-9218

BID: 71434