phpMyAdmin 4.2.x < 4.2.13.1 XSS (PMASA-2014-18)

Medium Nessus Network Monitor Plugin ID 8591

Synopsis

The remote web server contains a PHP application that is affected by a potential cross-site scripting (XSS) vulnerability.

Description

Versions of phpMyAdmin 4.2.x earlier than 4.2.13.1 are unpatched for a cross-site scripting vulnerability in the redirection mechanism that could be leveraged with a maliciously crafted URL being accessed.

Solution

Either upgrade to phpMyAdmin 4.2.13.1 or later, or apply the patches from the referenced links.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2014-18.php

Plugin Details

Severity: Medium

ID: 8591

Family: CGI

Published: 2014/12/08

Modified: 2016/03/02

Dependencies: 9102

Nessus ID: 79797

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2014/12/03

Vulnerability Publication Date: 2014/12/03

Reference Information

CVE: CVE-2014-9219

BID: 71435