Flash Player <= 15.0.0.223 Dereferenced Memory Pointer RCE (APSB14-26)

high Nessus Network Monitor Plugin ID 8585
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is running an outdated version of Adobe Flash Player for Internet Explorer which is affected by a remote code execution vulnerability.

Description

According to its version number, the instance of Flash Player on the remote host is exposed to an arbitrary code execution vulnerability by means of a malicious SWF file. This vulnerability exists due to the processing of a dereferenced memory pointer when handling SWF files.

Solution

Upgrade to version 15.0.0.239 or later.\n\nAlternatively, Adobe has made version 13.0.0.258 available for those who cannot be upgraded to 15.x.

See Also

http://www.nessus.org/u?0cb17c10

http://helpx.adobe.com/security/products/flash-player/apsb14-26.html

https://www.f-secure.com/weblog/archives/00002768.html

Plugin Details

Severity: High

ID: 8585

Family: Web Clients

Published: 3/27/2015

Updated: 3/6/2019

Dependencies: 5158

Nessus ID: 79442

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*

Patch Publication Date: 11/25/2014

Vulnerability Publication Date: 11/25/2014

Reference Information

CVE: CVE-2014-8439

BID: 71289