PHP 5.5.x < 5.5.18 Denial Of Service

low Nessus Network Monitor Plugin ID 8557
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is vulnerable to a Denial of Service attack.

Description

Versions of PHP 5.5 prior to 5.5.18 are vulnerable to a vulnerability which can allow a remote attacker to render the service unavailable. Specifically, the unserialize() function fails to properly parse user-supplied input.

Solution

Upgrade to version 5.5.18 or higher

See Also

https://bugs.php.net/bug.php?id=68044

Plugin Details

Severity: Low

ID: 8557

Family: Web Servers

Published: 10/17/2014

Updated: 3/6/2019

Dependencies: 8682

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 10/16/2014

Vulnerability Publication Date: 10/16/2014

Reference Information

CVE: CVE-2014-3669

BID: 70611