Squid 3.3.x < 3.3.13 / 3.4.x < 3.4.7 Request Parsing Vulnerability

Medium Nessus Network Monitor Plugin ID 8384

Synopsis

The remote proxy server is affected by a denial of service vulnerability.

Description

Squid versions prior to 3.3.13 and 3.4.7 are potentially affected by a denial of service vulnerability due to an error in the 'src/HttpHdrRange.cc' file.

Solution

Either upgrade to Squid version 3.3.13 / 3.4.7 or later, or apply the vendor-supplied patch.

See Also

http://www.squid-cache.org/Advisories/SQUID-2014_2.txt

Plugin Details

Severity: Medium

ID: 8384

Family: Web Servers

Published: 2014/09/11

Modified: 2016/11/23

Dependencies: 3389

Nessus ID: 77517

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Patch Publication Date: 2014/08/27

Vulnerability Publication Date: 2014/08/27

Reference Information

CVE: CVE-2014-3609

BID: 69453