Apache HTTP Server 2.4.1 to 2.4.4, 2.4.6, 2.4.7, 2.4.9 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8343


The remote web server is affected by multiple vulnerabilities.


Versions of Apache HTTP server 2.4.1 to 2.4.4, 2.4.6, 2.4.7, and 2.4.9 are unpatched for the following vulnerabilities:

- Memory consumption denial of service in WinNT MPM, which affects installations on the Windows platform (CVE-2014-3523)

- Race condition in scoreboard handling, which may potentially result in an exploitable heap buffer overflow (CVE-2014-0226)

- Denial of service when the 'mod_deflate' module attempts to process highly compressed bodies (CVE-2014-0118)

- Denial of service in 'mod_cgid' module when certain CGI scripts do not consume standard input and thus linger indefinitely, eventually causing the server to hang (CVE-2014-0231)


Upgrade to Apache HTTP Server 2.4.10, or later.

See Also


Plugin Details

Severity: Medium

ID: 8343

File Name: 8343.prm

Family: Web Servers

Published: 2014/07/29

Modified: 2018/02/20

Dependencies: 1442

Nessus ID: 76745

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.6

Temporal Score: 5.4


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.4.6

Patch Publication Date: 2014/07/15

Vulnerability Publication Date: 2014/07/14

Reference Information

CVE: CVE-2014-0231, CVE-2014-3523, CVE-2014-0118, CVE-2014-0226

BID: 68742, 68745, 68747, 68678

OSVDB: 109234, 109230, 109231, 109216

IAVA: 2014-A-0172, 2015-A-0060, 2015-A-0149