Samba < 3.6.23 / 4.0.16 / 4.1.6 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8276

Synopsis

The remote version of Samba is outdated and thus affected by multiple vulnerabilities.

Description

Versions of Samba older than 3.6.23 / 4.0.16 / 4.1.6 are unpatched for the following vulnerabilities:

- An information disclosure due to an error in the Security Account Manager Remote (SAMR) implementation, which fails to properly validate the lockout state for user accounts after a certain number of bad password attempts. (CVE-2013-4496)

- An error in the 'smbcacls' command causes the removal of access control lists (ACLs) when used with a '--chown' or '--chgrp' option, which could be leveraged by a remote attacker after an unintended administrative change to bypass intended restrictions. (CVE-2013-6442)

Solution

Install the patch referenced in the project's advisory, or upgrade to 3.6.23 / 4.0.16 / 4.1.6 or later.

See Also

http://www.samba.org/samba/security/CVE-2013-6442

http://www.samba.org/samba/security/CVE-2013-4496

https://www.samba.org/samba/history

https://www.samba.org/samba/history/security.html

Plugin Details

Severity: Medium

ID: 8276

Family: Samba

Published: 2014/06/03

Updated: 2019/03/06

Dependencies: 8740, 8741

Nessus ID: 73450

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 4.8

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2014/03/11

Vulnerability Publication Date: 2014/03/11

Reference Information

CVE: CVE-2013-4496, CVE-2013-6442

BID: 66336, 66232