Flash Player < 13.0.0.214 Multiple Vulnerabilities (APSB14-14)

High Nessus Network Monitor Plugin ID 8254

Synopsis

The remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.

Description

Versions of Adobe Flash player prior to 13.0.0.214 are outdated and thus unpatched for the following vulnerabilities :

- An overflow condition exists that is triggered as user-supplied input is not properly validated when handling display objects. This may allow a context-dependent attacker to cause a heap-based buffer overflow, allowing the execution of arbitrary code. (CVE-2014-0510)

- An unspecified vulnerability exists that could be used to bypass the same origin policy. (CVE-2014-0516)

- Multiple, unspecified security bypass vulnerabilities exist. (CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520)

Solution

Upgrade to Adobe Flash Player version 13.0.0.214 or later.

See Also

http://helpx.adobe.com/security/products/flash-player/apsb14-14.html

Plugin Details

Severity: High

ID: 8254

Family: Web Clients

Published: 2014/05/20

Modified: 2016/12/06

Dependencies: 5158

Nessus ID: 73994, 73996

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2014/05/13

Vulnerability Publication Date: 2014/03/13

Reference Information

CVE: CVE-2014-0510, CVE-2014-0516, CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520

BID: 66241, 67373, 67372, 67371, 67364, 67361