Flash Player < 184.108.40.206 Multiple Vulnerabilities (APSB14-14)
High Nessus Network Monitor Plugin ID 8254
SynopsisThe remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.
DescriptionVersions of Adobe Flash player prior to 220.127.116.11 are outdated and thus unpatched for the following vulnerabilities :
- An overflow condition exists that is triggered as user-supplied input is not properly validated when handling display objects. This may allow a context-dependent attacker to cause a heap-based buffer overflow, allowing the execution of arbitrary code. (CVE-2014-0510)
- An unspecified vulnerability exists that could be used to bypass the same origin policy. (CVE-2014-0516)
- Multiple, unspecified security bypass vulnerabilities exist. (CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520)
SolutionUpgrade to Adobe Flash Player version 18.104.22.168 or later.