Google Chrome < 34.0.1847.137 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 8251

Synopsis

The remote host is running an outdated web browser that contains multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote host is a version prior to 34.0.1847.137 and is thus missing fixes for the following vulnerabilities:

- Use-after-free error when handling WebSockets, and use-after-free error when calling the 'updateAppearance()' function in FrameSelection, which may be leveraged to access already freed memory and potentially execute arbitrary code. (CVE-2014-1740, CVE-2014-1742)

- An integer overflow condition in the 'deleteData()' and 'replaceData()' functions in CharacterData, which can be leveraged for denial of service or arbitrary code execution in the context of the application. (CVE-2014-1741)

- Various vulnerabilities in the built-in Flash player, which were fixed by updating to version 13.0.0.214.

Solution

Update the Chrome browser to 34.0.1847.137 or later.

See Also

http://googlechromereleases.blogspot.com/2014/05/stable-channel-update.html

http://helpx.adobe.com/security/products/flash-player/apsb14-14.html

Plugin Details

Severity: High

ID: 8251

File Name: 8251.prm

Family: Web Clients

Published: 2014/05/14

Modified: 2016/01/30

Dependencies: 4645

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Patch Publication Date: 2014/05/13

Vulnerability Publication Date: 2014/05/13

Reference Information

CVE: CVE-2014-1740, CVE-2014-1741, CVE-2014-1742

BID: 67374, 67375, 67376

OSVDB: 105750, 106914, 106915