CUPS < 1.7.2 Reflected Cross-Site Scripting Vulnerability

Low Nessus Network Monitor Plugin ID 8210

Synopsis

The remote host running a program that is vulnerable to reflected cross site scripting attacks (XSS).

Description

CUPS is a *nix-based network printing program. Versions of CUPS from 1.6.0 to 1.7.1 allow a reflected cross-site scripting (XSS) attack due to lack of input validation when returning requested resources to the user.

Solution

Upgrade to CUPS 1.7.2 or later.

See Also

http://www.cups.org/blog.php?L717

http://www.cups.org/documentation.php/relnotes.html

http://www.cups.org/str.php?L4356

https://bugs.mageia.org/show_bug.cgi?id=13196

https://bugzilla.redhat.com/show_bug.cgi?id=1087122

https://www.cups.org/documentation.php/doc-1.7/relnotes.html

http://www.cups.org/blog.php?L704

http://www.cups.org/str.php?L4319

Plugin Details

Severity: Low

ID: 8210

Family: Web Servers

Published: 2014/04/15

Updated: 2019/03/06

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 3.3

Temporal Score: 2.6

Vector: CVSS2#AV:A/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 4.2

Temporal Score: 3.8

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:cups:cups

Patch Publication Date: 2014/04/10

Vulnerability Publication Date: 2014/04/10

Reference Information

CVE: CVE-2014-2856

BID: 66788