Google Chrome < 33.0.1750.152 (Linux) Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 8164

Synopsis

The remote host is running an outdated web browser that contains multiple vulnerabilities.

Description

The Google Chrome browser detected on the remote Linux system is older than version 33.0.1750.152 and is therefore vulnerable to the following issues:

- Memory corruption vulnerability in Google V8 via ArrayBuffer property accesses. (CVE-2014-1705)

- Use-after-free error related to document.location bindings, which may be leveraged to execute arbitrary code by a context-dependent attacker. (CVE-2014-1713)

- A sandbox bypass via a flaw related to the clipboard message filter. (CVE-2014-1714)

- A sandbox bypass via path traversal due to insufficient user input sanitation in the 'CreatePlatformFileUnsafe()' function within 'base/platform_file_win.cc' (CVE-2014-1715)

Solution

Updates are available. Linux users should upgrade to 33.0.1750.152 or later.

See Also

http://googlechromereleases.blogspot.com/2014/03/stable-channel-update_14.html

http://www.pwn2own.com/2014/03/pwn2own-results-thursday-day-two/

Plugin Details

Severity: High

ID: 8164

Family: Web Clients

Published: 2014/03/18

Modified: 2016/12/06

Dependencies: 4645

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Patch Publication Date: 2014/03/14

Vulnerability Publication Date: 2014/03/14

Reference Information

CVE: CVE-2014-1705, CVE-2014-1713, CVE-2014-1714, CVE-2014-1715

BID: 66253, 66252, 66249, 66243, 66239