Synology DiskStation Manager <= 4.3-3827 'value' Parameter SQL Injection Vulnerability

High Nessus Network Monitor Plugin ID 8160

Synopsis

The remote host is a Synology DiskStation that is running an outdated version of the DiskStation Manager.

Description

The observed version of Synology DiskStation Manager is, or is older than, 4.3-3827, and as such is vulnerable to a SQL injection vulnerability due to insufficient user input sanitation of the 'value' parameter to the 'photo/include/blog/article.php' script prior to its use in a SQL query.

Solution

Upgrade to version 5.0, or higher, to address this vulnerability.

See Also

http://seclists.org/bugtraq/2014/Mar/80

Plugin Details

Severity: High

ID: 8160

Family: Web Servers

Published: 2014/03/14

Modified: 2016/02/05

Dependencies: 8248

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 7.3

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:U/RC:X

Vulnerability Information

CPE: cpe:/o:synology:linux:2.6

Patch Publication Date: 2014/03/12

Vulnerability Publication Date: 2014/03/12

Reference Information

BID: 66202