PHP 5.5.x < 5.5.10 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 8154

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

PHP versions earlier than 5.5.10 are potentially affected by the following vulnerabilities:

- An error related to the Fileinfo extension and the bundled libmagic library can be leveraged by an attacker for denial-of-service attacks (CVE-2014-1943)

- An error related to the Fileinfo extension and process for analyzing Portable Executable (PE) format files could be leveraged by an attacker for arbitrary code execution or denial of service (CVE-2014-2270)

- The fix for CVE-2013-7327 was incomplete, and has since been rectified (Bug 66815)

Solution

Apply the vendor patch or upgrade to PHP version 5.5.10 or later.

See Also

http://git.php.net/?p=php-src.git;a=commitdiff;h=a33759fd27

http://php.net/archive/2014.php#id2014-03-06-1

http://www.php.net/ChangeLog-5.php#5.5.10

Plugin Details

Severity: High

ID: 8154

File Name: 8154.prm

Family: Web Servers

Published: 2014/03/10

Modified: 2016/01/19

Dependencies: 8682

Nessus ID: 72882

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2014/03/06

Vulnerability Publication Date: 2014/03/06

Reference Information

CVE: CVE-2014-1943, CVE-2014-2270

BID: 65596, 66002