PHP 5.5.x < 5.5.10 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 8154


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


PHP versions earlier than 5.5.10 are potentially affected by the following vulnerabilities:

- An error related to the Fileinfo extension and the bundled libmagic library can be leveraged by an attacker for denial-of-service attacks (CVE-2014-1943)

- An error related to the Fileinfo extension and process for analyzing Portable Executable (PE) format files could be leveraged by an attacker for arbitrary code execution or denial of service (CVE-2014-2270)

- The fix for CVE-2013-7327 was incomplete, and has since been rectified (Bug 66815)


Apply the vendor patch or upgrade to PHP version 5.5.10 or later.

See Also;a=commitdiff;h=a33759fd27

Plugin Details

Severity: High

ID: 8154

Family: Web Servers

Published: 2014/03/10

Updated: 2019/03/06

Dependencies: 8682

Nessus ID: 72882

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2014/03/06

Vulnerability Publication Date: 2014/03/06

Reference Information

CVE: CVE-2014-1943, CVE-2014-2270

BID: 65596, 66002