Apple Quicktime 7.7.5 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 8140

Synopsis

The version of QuickTime on the remote machine is affected by multiple code execution vulnerabilities.

Description

Versions older than Quicktime 7.7.5 contain the following vulnerabilities:

- Multiple buffer overflow vulnerabilities, which can be leveraged by an attacker to execute arbitrary code or application termination (2014-1246, CVE-2014-1248, CVE-2014-1249)

- An out-of-bounds byte swapping issue in the handling of 'ttfo' elements, which can be leveraged by an attacker to execute arbitrary code or application termination (CVE-2014-1250)

- A signedness issue in the handling of 'stsz' atoms, which can be leveraged by an attacker to execute arbitrary code or application termination (CVE-2014-1245)

- A memory corruption issue when handling the 'dref' atoms, which can be leveraged by an attacker to execute arbitrary code or application termination (CVE-2014-1247)

Solution

Users of OS X Mavericks (v10.9) should upgrade to 10.9.2, which includes the Quicktime 7.7.5 update. All others should upgrade to version 7.7.5 or later.

See Also

http://support.apple.com/kb/HT6151

Plugin Details

Severity: Medium

ID: 8140

Family: Web Clients

Published: 2/26/2014

Updated: 3/6/2019

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 5.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apple:quicktime:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2014-1246, CVE-2014-1247, CVE-2014-1248, CVE-2014-1249, CVE-2014-1250, CVE-2014-1245

BID: 65786, 65787, 65784