FlashCanvas <= 1.5 Reflected Cross-site Scripting Attack

Medium Nessus Network Monitor Plugin ID 8110

Synopsis

The remote host is running a vulnerable version of FlashCanvas.

Description

Versions of FlashCanvas 1.5 and possibly earlier are vulnerable to a flaw that allows a reflected cross-site scripting (XSS) attack, due to lack of input validation of the referer header when submitted to the proxy.php script. An attacker could leverage this to execute arbitrary code in the user's browser within the security context of the browser and the server.

Solution

Upgrade to Flash Canvas Pro 1.6 or later. The vendor also advises removing proxy.php from the web directory if upgrading is not possible.

See Also

http://flashcanvas.net/release/1.6

http://packetstormsecurity.com/files/124404/FlashCanvas-1.5-Cross-Site-Scripting.html

http://www.7elements.co.uk/news/cve-2013-6880

Plugin Details

Severity: Medium

ID: 8110

Family: Web Servers

Published: 2014/02/11

Updated: 2019/03/06

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:shinyamuramatsu:flashcanvas

Patch Publication Date: 2013/12/11

Vulnerability Publication Date: 2013/12/11

Reference Information

CVE: CVE-2013-6880

BID: 64251