Oracle MySQL 5.1.x < 5.1.73 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 8088

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host is earlier than 5.1.73. Therefore, vulnerabilities likely exist in the following components :

- InnoDB
- Locking
- Optimizer
- Privileges
- Error Handling

Solution

Upgrade to MySQL version 5.1.73 or higher.

See Also

http://www.oracle.com/technetwork/topics/security/cpujan2014-1972949.html#AppendixMSQL

https://dev.mysql.com/doc/relnotes/mysql/5.1/en/news-5-1-73.html

Plugin Details

Severity: Medium

ID: 8088

Family: Database

Published: 2014/01/23

Updated: 2019/03/06

Dependencies: 8914

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Temporal Score: 4.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Patch Publication Date: 2014/12/03

Vulnerability Publication Date: 2014/01/14

Reference Information

CVE: CVE-2014-0412, CVE-2014-0402, CVE-2014-0386, CVE-2014-0401, CVE-2014-0437, CVE-2014-0393, CVE-2013-5908

BID: 64880, 64908, 64904, 64898, 64849, 64877, 64896