Apache Tomcat < 10.0.0-M7 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 701329
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Apache Tomcat server is affected by Multiple Vulnerabilities

Description

The version of Apache Tomcat installed on the remote host is < 10.0.0-M7. It is, therefore, affected by multiple vulnerabilities as referenced in the fixed_in_apache_tomcat_10.0.0-m7_security-10 advisory. Note that Nessus Network Monitor has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 10.0.0-M7 or later.

See Also

https://github.com/apache/tomcat/commit/1c1c77b0efb667cea80b532440b44cea1dc427c3,https://github.com/apache/tomcat/commit/c9167ae30f3b03b112f3d81772e3450b7d0e6a25,https://tomcat.apache.org/security-10.html#Fixed_in_Apache_Tomcat_10.0.0-M7

Plugin Details

Severity: High

ID: 701329

Family: Web Servers

Published: 4/14/2021

Updated: 4/14/2021

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 7/5/2020

Vulnerability Publication Date: 7/5/2020

Reference Information

CVE: CVE-2020-13934