Exim < 4.92.2 RCE

Critical Nessus Network Monitor Plugin ID 701176


The remote mail server is vulnerable to a Remote Command Execution (RCE) attack vector.


The remote host is running Exim, a message transfer agent.

Versions of Exim earlier than 4.92.2 are affected by a vulnerability that is exploitable by sending a SNI ending in a backslash-null sequence during the initial TLS handshake.


Upgrade to Exim 4.92.2 or later.

See Also


Plugin Details

Severity: Critical

ID: 701176

Family: SMTP Servers

Published: 2019/09/09

Updated: 2019/09/09

Dependencies: 2004, 2005

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Patch Publication Date: 2019/09/02

Vulnerability Publication Date: 2019/09/02

Reference Information

CVE: CVE-2019-15846