OpenSSH < 3.8p1 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 701169


Remote attackers may be able to cause information to leak from aborted sessions.


According to its banner, a version of OpenSSH earlier than 3.8p1 is running on the remote host and is affected by the following issues:

- There is an issue in the handling of PAM modules in such versions of OpenSSH. As a result, OpenSSH may not correctly handle aborted conversations with PAM modules. Consequently, that memory may not be scrubbed of sensitive information such as credentials, which could lead to credentials leaking into swap space and core dumps. Other vulnerabilities in PAM modules could come to light because of unpredictable behavior.

- Denial of service attacks are possible when privilege separation is in use. This version of OpenSSH does not properly signal non-privileged processes after session termination when 'LoginGraceTime' is exceeded. This can allow connections to remain open thereby allowing the denial of service when resources are exhausted. (CVE-2004-2069)


Upgrade to OpenSSH version 3.8p1 or later.

See Also,,,

Plugin Details

Severity: High

ID: 701169

Family: SSH

Published: 8/21/2019

Updated: 8/21/2019

Nessus ID: 44074

Risk Information


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Patch Publication Date: 11/17/2003

Vulnerability Publication Date: 9/2/2003

Reference Information

CVE: CVE-2004-2069

BID: 9040, 14963