Portable OpenSSH < 3.8p1 Multiple Vulnerabilities

Medium Nessus Plugin ID 44074


Remote attackers may be able to cause information to leak from aborted sessions.


According to its banner, a version of OpenSSH earlier than 3.8p1 is running on the remote host and is affected by the following issues:

- There is an issue in the handling of PAM modules in such versions of OpenSSH. As a result, OpenSSH may not correctly handle aborted conversations with PAM modules. Consequently, that memory may not be scrubbed of sensitive information such as credentials, which could lead to credentials leaking into swap space and core dumps. Other vulnerabilities in PAM modules could come to light because of unpredictable behavior.

- Denial of service attacks are possible when privilege separation is in use. This version of OpenSSH does not properly signal non-privileged processes after session termination when 'LoginGraceTime' is exceeded. This can allow connections to remain open thereby allowing the denial of service when resources are exhausted. (CVE-2004-2069)


Upgrade to OpenSSH 3.8p1 or later.

See Also






Plugin Details

Severity: Medium

ID: 44074

File Name: openssh_38p1.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Misc.

Published: 2011/10/04

Modified: 2016/12/07

Dependencies: 10267

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:U/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2003/11/17

Vulnerability Publication Date: 2003/09/02

Reference Information

CVE: CVE-2004-2069

BID: 9040, 14963

OSVDB: 16567, 75753