Portable OpenSSH < 3.8p1 Multiple Vulnerabilities

medium Nessus Plugin ID 44074


Remote attackers may be able to cause information to leak from aborted sessions.


According to its banner, a version of OpenSSH earlier than 3.8p1 is running on the remote host and is affected by the following issues:

- There is an issue in the handling of PAM modules in such versions of OpenSSH. As a result, OpenSSH may not correctly handle aborted conversations with PAM modules. Consequently, that memory may not be scrubbed of sensitive information such as credentials, which could lead to credentials leaking into swap space and core dumps. Other vulnerabilities in PAM modules could come to light because of unpredictable behavior.

- Denial of service attacks are possible when privilege separation is in use. This version of OpenSSH does not properly signal non-privileged processes after session termination when 'LoginGraceTime' is exceeded. This can allow connections to remain open thereby allowing the denial of service when resources are exhausted. (CVE-2004-2069)


Upgrade to OpenSSH 3.8p1 or later.

See Also






Plugin Details

Severity: Medium

ID: 44074

File Name: openssh_38p1.nasl

Version: 1.7

Type: remote

Family: Misc.

Published: 10/4/2011

Updated: 3/27/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: installed_sw/OpenSSH

Exploit Ease: No known exploits are available

Patch Publication Date: 11/17/2003

Vulnerability Publication Date: 9/2/2003

Reference Information

CVE: CVE-2004-2069

BID: 9040, 14963