Mozilla Firefox < 67.0.3 Security Vulnerability

medium Nessus Network Monitor Plugin ID 700740
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A web browser installed on the remote host is affected by a vulnerability.

Description

The version of Firefox installed on the remote host is prior to 67.0.3. It is, therefore, affected by following vulnerability as referenced in the mfsa2019-18 advisory:

- A type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop. This can allow for an exploitable crash. We are aware of targeted attacks in the wild abusing this flaw. (CVE-2019-11707)

Solution

Upgrade to Mozilla Firefox version 67.0.3 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2019-18/

Plugin Details

Severity: Medium

ID: 700740

Family: Web Clients

Published: 6/18/2019

Updated: 6/18/2019

Dependencies: 9131

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:*

Patch Publication Date: 6/18/2019

Vulnerability Publication Date: 6/18/2019

Reference Information

CVE: CVE-2019-11707