Exim < 4.92 RCE

High Nessus Network Monitor Plugin ID 700728

Synopsis

The remote mail server is vulnerable to a Remote Command Execution (RCE) attack vector.

Description

The remote host is running Exim, a message transfer agent.

Versions of Exim earlier than 4.92 are affected by a flaw due to improper validation of recipient address in 'deliver_message()' function in '/src/deliver.c' that may lead to remote command execution.

Solution

Upgrade to Exim 4.92 or later.

See Also

https://www.exim.org/static/doc/security/CVE-2019-10149.txt

https://www.openwall.com/lists/oss-security/2019/06/05/4

Plugin Details

Severity: High

ID: 700728

Family: SMTP Servers

Published: 2019/06/06

Updated: 2019/06/06

Dependencies: 2004, 2005

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Patch Publication Date: 2018/06/05

Vulnerability Publication Date: 2018/06/05

Reference Information

CVE: CVE-2019-10149