MariaDB Server 10.2.x < 10.2.24 Multiple DoS

High Nessus Network Monitor Plugin ID 700716

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

The version of MariaDB installed on the remote host is 10.2.x prior to 10.2.24, and is affected by multiple difficult to exploit vulnerabilities that allow a high privileged attacker with network access via multiple protocols to compromise MariaDB Server. Successful attacks of these vulnerabilities can result in unauthorized ability to cause a hang or frequently repeatable crash resulting in partial to complete denial of service. (CVE-2019-2614, CVE-2019-2627, CVE-2019-2628)

Solution

Upgrade to version 10.2.24 or later.

See Also

https://mariadb.com/kb/en/mdb-10224-rn

Plugin Details

Severity: High

ID: 700716

Family: Database

Published: 2019/05/21

Updated: 2019/05/21

Dependencies: 8693

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.4

Temporal Score: 3.9

Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Patch Publication Date: 2019/04/25

Vulnerability Publication Date: 2019/04/25

Reference Information

CVE: CVE-2019-2614, CVE-2019-2627, CVE-2019-2628

BID: 107927