Apache Tomcat 9.0.x < 9.0.19 Remote Code Execution Vulnerability (Windows)

high Nessus Network Monitor Plugin ID 700711

Synopsis

The remote Windows Apache Tomcat server is affected by a remote code execution vulnerability.

Description

The version of Tomcat installed on the remote Windows host is prior to 9.0.19. It is, therefore, affected by a remote code execution vulnerability due to a bug in the way the JRE passes command line arguments to Windows. An unauthenticated, remote attacker can exploit this to execute arbitrary commands. Additionally, it is affected by a cross-site (XSS) scripting vulnerability as the SSI printenv command echoes user provided data without proper escaping.

Note that Nessus Network Monitor has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 9.0.19 or later.\nThe issues below were fixed in Apache Tomcat 9.0.18 but the release vote for the 9.0.18 release candidate did not pass. Therefore, although users must download 9.0.19 to obtain a version that includes a fix for these issues, version 9.0.18 is not included in the list of affected versions.

See Also

http://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.19

http://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.19,https://github.com/apache/tomcat/commit/4b244d8,http://www.nessus.org/u?387f17bf

Plugin Details

Severity: High

ID: 700711

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 124058

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 4/10/2019

Vulnerability Publication Date: 4/10/2019

Reference Information

CVE: CVE-2019-0221, CVE-2019-0232

BID: 107906

IAVB: 2019-B-0027