Apache Tomcat 9.0.x < 9.0.2 Insecure CGI Servlet Search Algorithm Description Weakness

medium Nessus Network Monitor Plugin ID 700704

Synopsis

The remote Apache Tomcat server is affected by a flaw in the CGI Servlet search algorithm.

Description

The version of Apache Tomcat installed on the remote host is 9.0.x prior to 9.0.2. It is, therefore, affected by a flaw that is due to the program containing an incorrect description for the CGI Servlet search algorithm, which may cause an administrator to leave the system in an insecure state.

Solution

Upgrade to Apache Tomcat version 9.0.2 or later.

See Also

http://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.2

Plugin Details

Severity: Medium

ID: 700704

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 106713

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 11/30/2017

Vulnerability Publication Date: 1/31/2018

Reference Information

CVE: CVE-2017-15706

BID: 103069