Apache Tomcat 8.5.x < 8.5.28 Security Constraint Weakness

medium Nessus Network Monitor Plugin ID 700693

Synopsis

The remote web server is missing an Apache Tomcat patch update.

Description

The version of Apache Tomcat installed on the remote host is version 8.5.x prior to 8.5.28. It is, therefore, affected by a security constraints flaw which could expose resources to unauthorized users.

Solution

Upgrade to Apache Tomcat version 8.5.28 or later.

See Also

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.28

Plugin Details

Severity: Medium

ID: 700693

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 106977

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 2/13/2018

Vulnerability Publication Date: 2/12/2018

Reference Information

CVE: CVE-2018-1304, CVE-2018-1305

BID: 103170, 103144