Apache Tomcat 8.0.x < 8.0.44 Remote Error Page Manipulation

medium Nessus Network Monitor Plugin ID 700684
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Apache Tomcat server is affected by a remote error page manipulation vulnerability.

Description

The version of Apache Tomcat installed on the remote host is version 8.0.x prior to 8.0.44. It is, therefore, affected by an implementation flaw in the error page reporting mechanism in which it does not conform to the Java Servlet Specification that requires static error pages to be processed as an HTTP GET request nothwithstanding the HTTP request method that was originally used when the error occurred. Depending on the original request and the configuration of the Default Servlet, an unauthenticated, remote attacker can exploit this issue to replace or remove custom error pages.

Note that Nessus Network Monitor has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 8.0.44 or later.

See Also

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.0.44

Plugin Details

Severity: Medium

ID: 700684

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 100681

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 5/10/2017

Vulnerability Publication Date: 6/6/2017

Reference Information

CVE: CVE-2017-5664

BID: 98888