Apache Tomcat 7.0.x < 7.0.82 RCE

medium Nessus Network Monitor Plugin ID 700675

Synopsis

The remote Apache Tomcat server is affected by a code execution vulnerability.

Description

The version of Apache Tomcat installed on the remote host is version 7.x prior to 7.0.82. It is, therefore, affected by an unspecified vulnerability when running with HTTP PUTs enabled (e.g. via setting the readonly initialization parameter of the Default to false) that makes it possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it contained would be executed by the server.

Note that Nessus Network Monitor has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.82 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.82

Plugin Details

Severity: Medium

ID: 700675

Family: Web Servers

Published: 5/13/2019

Updated: 5/13/2019

Nessus ID: 103698

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 9/20/2017

Vulnerability Publication Date: 9/20/2017

Reference Information

CVE: CVE-2017-12617

BID: 100954