Drupal 7.x < 7.67 / 8.6.x < 8.6.16 / 8.7.x < 8.7.1 (SA-CORE-2019-007)

High Nessus Network Monitor Plugin ID 700664


A PHP application running on the remote web server is affected by a path traversal vulnerability.


According to its self-reported version, the instance of Drupal running on the remote web server is 7.0.x prior to 7.67, 8.6.x prior to 8.6.x, or 8.7.x prior to 8.7.1. It is, therefore, affected by a path traversal vulnerability. This security release fixes third-party dependencies included in or required by Drupal core.
As described in TYPO3-PSA-2019-007: By-passing protection of Phar Stream Wrapper Interceptor: In order to intercept file invocations like file_exists or stat on compromised Phar archives the base name has to be determined and checked before allowing to be handled by PHP Phar stream handling. The current implementation is vulnerable to path traversal leading to scenarios where the Phar archive to be assessed is not the actual (compromised) file.


Upgrade to Drupal 8.7.1, or later. If 8.7.x cannot be obtained, 8.6.16 and 7.67 have also been patched for this vulnerability.

See Also






Plugin Details

Severity: High

ID: 700664

Family: CGI

Published: 2019/05/08

Updated: 2019/05/13

Dependencies: 9211, 9212

Nessus ID: 124698

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Patch Publication Date: 2019/05/08

Vulnerability Publication Date: 2019/05/08

Reference Information

CVE: CVE-2019-11831

BID: 108302