Drupal 7.0.x < 7.67 / 8.6.x < 8.6.16 / 8.7.x < 8.7.1 Drupal Vulnerability (SA-CORE-2019-007)

High Nessus Plugin ID 124698

Synopsis

A PHP application running on the remote web server is affected by a path traversal vulnerability.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 7.0.x prior to 7.67, 8.7.x prior to 8.6.16, or 8.7.x prior to 8.7.1. It is, therefore, affected by a path traversal vulnerability. This security release fixes third-party dependencies included in or required by Drupal core.
As described in TYPO3-PSA-2019-007: By-passing protection of Phar Stream Wrapper Interceptor: In order to intercept file invocations like file_exists or stat on compromised Phar archives the base name has to be determined and checked before allowing to be handled by PHP Phar stream handling. The current implementation is vulnerable to path traversal leading to scenarios where the Phar archive to be assessed is not the actual (compromised) file. (SA-CORE-2019-007)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 7.67 / 8.6.16 / 8.7.1 or later.

See Also

https://www.drupal.org/sa-core-2019-007

https://typo3.org/security/advisory/typo3-psa-2019-007/

https://www.drupal.org/project/drupal/releases/7.67

https://www.drupal.org/project/drupal/releases/8.6.16

https://www.drupal.org/project/drupal/releases/8.7.1

Plugin Details

Severity: High

ID: 124698

File Name: drupal_8_6_16.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/05/08

Updated: 2019/05/10

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-11831

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Patch Publication Date: 2019/05/08

Vulnerability Publication Date: 2019/05/08

Reference Information

CVE: CVE-2019-11831