Atlassian Confluence < 6.6.12 / 6.7.x < 6.12.3 / 6.13.x < 6.13.3 / 6.14.x < 6.14.2 Multiple Vulnerabilities

Critical Nessus Network Monitor Plugin ID 700661

Synopsis

The remote Confluence server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the Atlassian Confluence application running on the remote host is prior to 6.6.12, 6.7.x prior to 6.12.3, 6.13.x prior to 6.13.3, or 6.14.x prior to 6.14.2. It is, therefore, affected by the following vulnerabilities:

- A server-side request forgery (SSRF) exists in the WebDAV plugin due to improper input validation. An attacker can exploit this, via unspecified vectors, to send arbitrary HTTP and WebDAV requests from the application. (CVE-2019-3395)
- A server-side template injection exists in the Widget Connector due to improper input validation. An attacker can exploit this, via unspecified vectors, to traverse directories or execute arbitrary code. (CVE-2019-3396)

Solution

Upgrade to Atlassian Confluence version 6.6.12, 6.12.3, 6.13.3, 6.14.2, 6.15.1 or later.

See Also

http://www.nessus.org/u?b8e8304c

Plugin Details

Severity: Critical

ID: 700661

Family: CGI

Published: 2019/05/02

Updated: 2019/05/02

Dependencies: 9543

Nessus ID: 123008

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Patch Publication Date: 2019/03/20

Vulnerability Publication Date: 2019/03/20

Reference Information

CVE: CVE-2019-3395, CVE-2019-3396

BID: 107543

IAVA: 2019-A-0135