MySQL 5.6.x < 5.6.44 Multiple Vulnerabilities (Apr 2019 CPU)

Medium Nessus Network Monitor Plugin ID 700632

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.6.x prior to 5.6.44. It is, therefore, affected by multiple vulnerabilities, including three of the top vulnerabilities below, as noted in the April 2019 Critical Patch Update advisory:

- An unspecified vulnerability in the 'Server: Compiling (OpenSSL)' subcomponent could allow an unauthenticated attacker to gain complete access to all MySQL Server accessible data. (CVE-2019-1559)

- An unspecified vulnerability in the 'Server: Options' subcomponent could allow a high privileged attacker to hang or to, via a frequently repeatable crash, cause a complete denial of service. (CVE-2019-2683)

- An unspecified vulnerability in the 'Server: Security: Privileges' subcomponent could allow a high privileged attacker to hang or to, via a frequently repeatable crash, cause a complete denial of service. (CVE-2019-2627)

Solution

Upgrade to MySQL version 5.6.44 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-44.html

http://www.nessus.org/u?e6252734

Plugin Details

Severity: Medium

ID: 700632

Family: Database

Published: 2019/04/25

Updated: 2019/04/25

Dependencies: 8914

Nessus ID: 124158

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 5

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2019/04/16

Vulnerability Publication Date: 2019/04/16

Reference Information

CVE: CVE-2019-1559, CVE-2019-2683, CVE-2019-2627, CVE-2019-2614

BID: 107174, 107927

IAVA: 2019-A-0122