MySQL 5.7.x < 5.7.21 Multiple Vulnerabilities (January 2018 CPU)

high Nessus Network Monitor Plugin ID 700625
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.7.x prior to 5.7.21. It is, therefore, affected by multiple vulnerabilities as noted in the January 2018 Critical Patch Update advisory. Please consult the CVRF details for the applicable CVEs for additional information.

Solution

Upgrade to MySQL version 5.7.21 or later.

See Also

http://www.nessus.org/u?ae82f1b1

http://www.nessus.org/u?17a0bb67

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-21.html

Plugin Details

Severity: High

ID: 700625

Family: Database

Published: 4/25/2019

Updated: 4/25/2019

Dependencies: 8914

Nessus ID: 106101

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:oracle:mysql:*:*:*:*:*:*:*:*

Patch Publication Date: 1/16/2018

Vulnerability Publication Date: 1/16/2018

Reference Information

CVE: CVE-2017-3737, CVE-2018-2562, CVE-2018-2622, CVE-2018-2640, CVE-2018-2665, CVE-2018-2668, CVE-2018-2612, CVE-2018-2565, CVE-2018-2573, CVE-2018-2576, CVE-2018-2583, CVE-2018-2586, CVE-2018-2590, CVE-2018-2600, CVE-2018-2645, CVE-2018-2646, CVE-2018-2647, CVE-2018-2667, CVE-2018-2696, CVE-2018-2703, CVE-2018-2591

BID: 102103, 102701, 102682, 102706, 102678, 102681, 102495, 102697, 102698, 102703, 102704, 102708, 102710