Grandstream GXV3370 < 1.0.1.41 RCE

high Nessus Network Monitor Plugin ID 700498
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is using a Grandstream GXV3370 device that is vulnerable to a Remote Code Execution (RCE) attack vector.

Description

The remote host is running a Grandstream GXV3370 device, firmware version prior to 1.0.1.41 , and is therefore affected by a RCE attack vector that allows remote authenticated users to execute arbitrary code via shell metacharacters in a '/manager?action=getlogcat' priority field.

Solution

Upgrade to Grandstream GXV3370 firmware version 1.0.1.41 or later.

See Also

https://www.tenable.com/blog/multiple-remote-code-execution-vulnerabilities-found-in-grandstream-devices

https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920

https://threatpost.com/grandstream-bugs-smbs-attacks/143141

Plugin Details

Severity: High

ID: 700498

Family: IoT

Published: 4/5/2019

Updated: 4/6/2019

Dependencies: 700495

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:h:grandstreamnetworks:gxv3370:*:*:*:*:*:*:*:*

Patch Publication Date: 3/22/2019

Vulnerability Publication Date: 3/22/2019

Reference Information

CVE: CVE-2019-10659