CVE-2019-10659

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Grandstream GXV3370 before 1.0.1.41 and WP820 before 1.0.3.6 devices allow remote authenticated users to execute arbitrary code via shell metacharacters in a /manager?action=getlogcat priority field.

References

https://github.com/scarvell/grandstream_exploits

https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1

Details

Source: MITRE

Published: 2019-03-30

Updated: 2020-08-24

Type: CWE-78

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
124173Multiple Command Injection Vulnerabilities in Grandstream ProductsNessusMisc.
critical
700498Grandstream GXV3370 < 1.0.1.41 RCENessus Network MonitorIoT
high
123520Multiple Command Injection Vulnerabilities in Grandstream ProductsNessusMisc.
critical
700008Moodle 2.7.x < 2.7.19 RCENessus Network MonitorCGI
critical