Grandstream IP PBX Appliance UCM6204 < 1.0.19.20 RCE

High Nessus Network Monitor Plugin ID 700492

Synopsis

The remote server is running a Grandstream IP PBX Appliance device that is vulnerable to a Remote Code Execution (RCE) attack vector.

Description

The remote host is running a Grandstream UCM6204 IP PBX, firmware version prior to 1.0.19.20, and is therefore affected by a RCE attack vector. An attacker can exploit a blind command injection vulnerability in the "file-backup" parameter of the 'backupUCMConfig' API call allowing the execution of arbitrary code. (CVE-2019-10662) A vulnerability allows remote authenticated users to conduct SQL injection attacks via the sord parameter in a listCodeblueGroup API call to the '/cgi?' URI. (CVE-2019-10663)

Solution

Upgrade to Grandstream UCM6204 IP PBX firmware version 1.0.19.20 or later.

See Also

https://www.tenable.com/blog/multiple-remote-code-execution-vulnerabilities-found-in-grandstream-devices

https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920

https://threatpost.com/grandstream-bugs-smbs-attacks/143141

Plugin Details

Severity: High

ID: 700492

Family: IoT

Published: 2019/04/05

Updated: 2019/04/06

Dependencies: 700485

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/h:grandstreamnetworks:ucm6204

Patch Publication Date: 2019/03/22

Vulnerability Publication Date: 2019/03/22

Reference Information

CVE: CVE-2019-10662, CVE-2019-10663