CVE-2019-10662

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Grandstream UCM6204 before 1.0.19.20 devices allow remote authenticated users to execute arbitrary code via shell metacharacters in the backupUCMConfig file-backup parameter to the /cgi? URI.

References

https://github.com/scarvell/grandstream_exploits

https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1

Details

Source: MITRE

Published: 2019-03-30

Updated: 2020-08-24

Type: CWE-78

Risk Information

CVSS v2

Base Score: 9

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8

Severity: HIGH

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
124173Multiple Command Injection Vulnerabilities in Grandstream ProductsNessusMisc.
critical
700492Grandstream IP PBX Appliance UCM6204 < 1.0.19.20 RCENessus Network MonitorIoT
high
123520Multiple Command Injection Vulnerabilities in Grandstream ProductsNessusMisc.
critical