Flash Player < 30.0.0.154 Multiple Vulnerabilities (APSB18-25)

High Nessus Network Monitor Plugin ID 700436

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by multiple attack vectors.

Description

Versions of Adobe Flash Player prior to 30.0.0.154 are unpatched, and therefore affected by multiple vulnerabilities :

- An out-of-bounds read vulnerability exists that could lead to information disclosure. (CVE-2018-12824, CVE-2018-12826, CVE-2018-12827)
- A security bypass vulnerability exists that could lead to security mitigation bypass. (CVE-2018-12825)
- A "use of a component with a known vulnerability" vulnerability exists that could lead to privilege escalation. (CVE-2018-12828)

Solution

Upgrade to Adobe Flash Player version 30.0.0.154 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-25.html

Plugin Details

Severity: High

ID: 700436

Family: Web Clients

Published: 2019/03/20

Updated: 2019/04/09

Dependencies: 5158

Nessus ID: 111683

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2018/08/14

Vulnerability Publication Date: 2018/08/14

Reference Information

CVE: CVE-2018-12824, CVE-2018-12825, CVE-2018-12826, CVE-2018-12827, CVE-2018-12828

BID: 105066, 105070, 105071