Flash Player < 30.0.0.113 Multiple Vulnerabilities (APSB18-19)

Critical Nessus Network Monitor Plugin ID 700434

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by multiple attack vectors.

Description

Versions of Adobe Flash Player prior to 30.0.0.113 are unpatched, and therefore affected by multiple vulnerabilities :

- A type confusion vulnerability exists that could lead to arbitrary code execution. (CVE-2018-4945)
- An integer overflow vulnerability exists that could lead to information disclosure. (CVE-2018-5000)
- An out-of-bounds read vulnerability exists that could lead to information disclosure. (CVE-2018-5001)
- A stack-based buffer overflow vulnerability exists that could lead to arbitrary code execution. (CVE-2018-5002)

Solution

Upgrade to Adobe Flash Player version 30.0.0.113 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-19.html

Plugin Details

Severity: Critical

ID: 700434

Family: Web Clients

Published: 2019/03/20

Updated: 2019/04/09

Dependencies: 5158

Nessus ID: 110397

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.7

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2018/06/07

Vulnerability Publication Date: 2018/06/07

Reference Information

CVE: CVE-2018-4945, CVE-2018-5000, CVE-2018-5001, CVE-2018-5002

BID: 104413