Flash Player < 28.0.0.161 Multiple RCE (APSB18-03)

Critical Nessus Network Monitor Plugin ID 700430

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by multiple remote code execution attack vectors.

Description

Versions of Adobe Flash Player prior to 28.0.0.161 are unpatched for multiple vulnerabilities :

- A vulnerability exists due to a dangling pointer in the Primetime SDK related to media player's quality of service functionality. A successful attack can lead to arbitrary code execution. (CVE-2018-4877)
- A vulnerability exists due to a dangling pointer in the Primetime SDK related to media player handling of listener objects. A successful attack can lead to arbitrary code execution.

Solution

Upgrade to Adobe Flash Player version 28.0.0.161 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsa18-03.html

Plugin Details

Severity: Critical

ID: 700430

Family: Web Clients

Published: 2019/03/20

Updated: 2019/04/09

Dependencies: 5158

Nessus ID: 106606

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2018/02/01

Vulnerability Publication Date: 2018/02/01

Reference Information

CVE: CVE-2018-4877, CVE-2018-4878

BID: 102893, 102930