Flash Player < 18.104.22.168 Multiple Vulnerabilities (APSB17-33)
Critical Nessus Network Monitor Plugin ID 700427
SynopsisThe remote host is running an outdated version of Adobe Flash Player that is affected by multiple attack vectors.
DescriptionVersions of Adobe Flash Player prior to 22.214.171.124 are unpatched, and therefore affected by multiple vulnerabilities :
- An invalid (out-of-range) pointer vulnerability exists offset during access of internal data structure fields. A successful attack can lead to sensitive data exposure. (CVE-2017-3112, CVE-2017-3114, CVE-2017-11213)
- The mismatch between an old and a new object can provide an attacker with unintended memory access potentially leading to code corruption, control-flow hijack, or an information leak attack. Successful exploitation could lead to arbitrary code execution. (CVE-2017-11215, CVE-2017-11225)
SolutionUpgrade to Adobe Flash Player version 126.96.36.199 or later.