Flash Player < 27.0.0.187 Multiple Vulnerabilities (APSB17-33)

Critical Nessus Network Monitor Plugin ID 700427

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by multiple attack vectors.

Description

Versions of Adobe Flash Player prior to 27.0.0.187 are unpatched, and therefore affected by multiple vulnerabilities :

- An invalid (out-of-range) pointer vulnerability exists offset during access of internal data structure fields. A successful attack can lead to sensitive data exposure. (CVE-2017-3112, CVE-2017-3114, CVE-2017-11213)
- The mismatch between an old and a new object can provide an attacker with unintended memory access potentially leading to code corruption, control-flow hijack, or an information leak attack. Successful exploitation could lead to arbitrary code execution. (CVE-2017-11215, CVE-2017-11225)

Solution

Upgrade to Adobe Flash Player version 27.0.0.187 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb17-33.html

Plugin Details

Severity: Critical

ID: 700427

Family: Web Clients

Published: 2019/03/20

Updated: 2019/04/09

Dependencies: 5158

Nessus ID: 104544

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2017/11/14

Vulnerability Publication Date: 2017/11/14

Reference Information

CVE: CVE-2017-3112, CVE-2017-3114, CVE-2017-11213, CVE-2017-11215, CVE-2017-11225

BID: 101837