Flash Player < 27.0.0.130 Multiple RCE (APSB17-28)

High Nessus Network Monitor Plugin ID 700425

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by multiple remote code execution (RCE) attack vectors.

Description

Versions of Adobe Flash Player prior to 27.0.0.130 are unpatched, and therefore affected by multiple vulnerabilities :

- An unspecified memory corruption flaw exists that is caused by input not being properly validated. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a website containing specially crafted Flash content, to to corrupt memory and potentially execute arbitrary code. (CVE-2017-11281, CVE-2017-11282)

Solution

Upgrade to Adobe Flash Player version 27.0.0.130 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb17-28.html

Plugin Details

Severity: High

ID: 700425

Family: Web Clients

Published: 2019/03/20

Updated: 2019/04/09

Dependencies: 5158

Nessus ID: 103124

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2017/09/12

Vulnerability Publication Date: 2017/09/12

Reference Information

CVE: CVE-2017-11281, CVE-2017-11282

BID: 100710, 100716