Flash Player < 26.0.0.151 Multiple Vulnerabilities (APSB17-23)

High Nessus Network Monitor Plugin ID 700424

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by multiple attack vectors.

Description

Versions of Adobe Flash Player prior to 26.0.0.151 are unpatched, and therefore affected by multiple vulnerabilities :

- An information disclosure vulnerability exists due to an unspecified flaw. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a website containing specially crafted Flash content, to disclose sensitive information. (CVE-2017-3085)
- A remote code execution vulnerability exists due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, by convincing a user to visit a website containing specially crafted Flash content, to execute arbitrary code. (CVE-2017-3106)

Solution

Upgrade to Adobe Flash Player version 26.0.0.151 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb17-23.html

Plugin Details

Severity: High

ID: 700424

Family: Web Clients

Published: 2019/03/07

Updated: 2019/04/09

Dependencies: 5158

Nessus ID: 102262

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2017/08/08

Vulnerability Publication Date: 2017/08/08

Reference Information

CVE: CVE-2017-3085, CVE-2017-3106

BID: 100191