Mozilla Firefox < 62.0.2 DoS

High Nessus Network Monitor Plugin ID 700408

Synopsis

The remote host has a web browser installed that is vulnerable to a Denial of Service (DoS) attack vector.

Description

Versions of Mozilla Firefox prior to 62.0.2 are unpatched for a potentially exploitable crash in 'TransportSecurityInfo' used for SSL can be triggered by data stored in the local cache in the user profile directory. This issue is only exploitable in combination with another vulnerability allowing an attacker to write data into the local cache or from locally installed malware. This issue also triggers a non-exploitable startup crash for users switching between the Nightly and Release versions of Firefox if the same profile is used.

Solution

Upgrade to Firefox version 62.0.2 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2018-22

Plugin Details

Severity: High

ID: 700408

Family: Web Clients

Published: 2019/02/07

Updated: 2019/03/06

Dependencies: 9131

Nessus ID: 117668

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7

Temporal Score: 5.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 6.4

Temporal Score: 4.4

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Patch Publication Date: 2018/09/21

Vulnerability Publication Date: 2018/09/21

Reference Information

CVE: CVE-2018-12385

BID: 105380