Oracle MySQL 5.7.x < 5.7.24 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 700392

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

Several issues have been discovered in the MySQL database server. The vulnerabilities are addressed by upgrading MySQL to the new upstream version 5.7.24, which includes additional changes, such as performance improvements, bug fixes, new features, and possibly incompatible changes. Please see Oracle's Critical Patch Update advisory for further details.

Solution

Upgrade to MySQL 5.7.24 or later.

See Also

https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html

https://www.tenable.com/blog/oracle-s-january-critical-patch-update-addresses-nearly-300-fixes

Plugin Details

Severity: Medium

ID: 700392

Family: Database

Published: 2019/01/16

Updated: 2019/03/06

Dependencies: 8914

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:A/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.1

Temporal Score: 6.3

Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2019/01/15

Vulnerability Publication Date: 2019/01/15

Reference Information

CVE: CVE-2018-0734, CVE-2019-2420, CVE-2019-2434, CVE-2019-2455, CVE-2019-2481, CVE-2019-2482, CVE-2019-2486, CVE-2019-2503, CVE-2019-2507, CVE-2019-2510, CVE-2019-2528, CVE-2019-2529, CVE-2019-2531, CVE-2019-2532, CVE-2019-2534, CVE-2019-2537

BID: 106462, 106619, 106627